[(slightly) O/T] zic & leap seconds on Solaris 9

Mariano Absatz baby at baby.com.ar
Tue May 6 14:12:03 UTC 2003


I usually don't compile and install tzcode, and simply use the latest tzdata 
and compile the zones I need with the zic that my OS has...

This has worked for linux and Solaris... or at least as far as I remember... 
now I wanted to use the "right" zones on a Solaris 9 machine and found that 
the zic that comes with Solaris doesn't support the "-L" option...

So I downloaded & compiled tzcode (only adjusted the "cc = cc" line for using 

Everything went fine, I didn't install the software (it is in my home 
directory), but I ran:
zic -d /usr/share/lib/zoneinfo/right -L leapseconds northamerica
and it generated a new set of zone files in that directory.

However, setting TZ to right/America/Mexico_City works exactly the same as if 
it were America/Mexico_City (i.e. I have _no_ 22 seconds difference).

My (uninformed) guess is that maybe the old libraries cannot understand leap 
seconds although they are compiled in the zone files...

I have a couple of questions:
Am I completely off-base? :-)

How could I replace the old version of the zoneinfo database, tools and 
libraries with a newer one?

Browsing the Makefile, I see that the distribution of files is quite 
different from the one that appears to be standard in Solaris.

Does anyone know of a ready-made Solaris 9 package I can use?

I don't even know how to "uninstall" the default libraries or which files are 
involved... they don't appear to have the same names...

This is a production machine and I wouldn't like to break it just to set the 
clock right :-)

Any Solaris+Olson expertise would be greatly appreciated.


Mariano Absatz - El Baby
mailto:baby at baby.com.ar
    PGP KEYS: 
  |\  _
  _\\/'>     Powered by Pegasus Mail
 /|__)       http://www.pmail.com
  ) )\

More information about the tz mailing list