[tz] [PROPOSED 1/2] Rename ‘lint’ to ‘GCC_LINT’

Paul Eggert eggert at cs.ucla.edu
Thu May 18 23:15:57 UTC 2017


* Makefile (GCC_DEBUG_FLAGS):
* private.h (INITIALIZE): Rename ‘lint’ to ‘GCC_LINT’, as the
macro is intended for GCC, not for traditional ‘lint’.
---
 Makefile  | 2 +-
 private.h | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/Makefile b/Makefile
index e7c6ac0..bcfdcb2 100644
--- a/Makefile
+++ b/Makefile
@@ -159,7 +159,7 @@ LDLIBS=
 #	(or some other number) to set the maximum time zone abbreviation length
 #	that zic will accept without a warning (the default is 6)
 #  $(GCC_DEBUG_FLAGS) if you are using recent GCC and want lots of checking
-GCC_DEBUG_FLAGS = -Dlint -g3 -O3 -fno-common -fstrict-aliasing \
+GCC_DEBUG_FLAGS = -DGCC_LINT -g3 -O3 -fno-common -fstrict-aliasing \
 	-Wall -Wextra \
 	-Wbad-function-cast -Wcast-align -Wdate-time \
 	-Wdeclaration-after-statement \
diff --git a/private.h b/private.h
index e9eb211..6886185 100644
--- a/private.h
+++ b/private.h
@@ -566,7 +566,7 @@ static time_t const time_t_max = MAXVAL(time_t, TYPE_BIT(time_t));
 ** INITIALIZE(x)
 */
 
-#ifdef lint
+#ifdef GCC_LINT
 # define INITIALIZE(x)	((x) = 0)
 #else
 # define INITIALIZE(x)
-- 
2.9.4



More information about the tz mailing list