[tz] [PROPOSED 2/5] Pacify gcc -std=c89 -pedantic with new attributes

Paul Eggert eggert at cs.ucla.edu
Mon Nov 28 19:47:04 UTC 2022

On 2022-11-28 05:40, Philip Newton wrote:
> "have has" is a bit ugly....

Yes, I originally used the name "HAVE___HAS_C_ATTRIBUTE", since it tests 
whether __has_c_attribute exists and that's the naming convention, but I 
changed it to HAVE_HAS_C_ATTRIBUTE as I worried that the three adjacent 
underscores would be confusing. If people prefer HAVE___HAS_C_ATTRIBUTE 
we can easily change to that. The longer name would be more consistent.

More information about the tz mailing list