>From 035492ecf69ff71e3ddc3924992cd8681ce81577 Mon Sep 17 00:00:00 2001 From: Roland Young Date: Tue, 15 Oct 2019 09:50:36 -0700 Subject: [PATCH] Rename asctime symbols if required in private.h * private.h (asctime, asctime_r): Rename these to tz_asctime, tz_asctime_r if renaming the other identifiers. --- private.h | 6 ++++++ 1 file changed, 6 insertions(+) diff --git a/private.h b/private.h index 1ead147..87f923a 100644 --- a/private.h +++ b/private.h @@ -409,6 +409,10 @@ static time_t sys_time(time_t *x) { return time(x); } typedef time_tz tz_time_t; +# undef asctime +# define asctime tz_asctime +# undef asctime_r +# define asctime_r tz_asctime_r # undef ctime # define ctime tz_ctime # undef ctime_r @@ -478,6 +482,8 @@ typedef time_tz tz_time_t; # define altzone tz_altzone # endif +char *asctime(struct tm const *); +char *asctime_r(struct tm const *restrict, char *restrict); char *ctime(time_t const *); char *ctime_r(time_t const *, char *); double difftime(time_t, time_t) ATTRIBUTE_CONST; -- 2.17.1