[tz] Issue in Time Zone Database for Kazakhstan's zones

Brian Inglis Brian.Inglis at systematicsw.ab.ca
Thu Apr 28 18:31:17 UTC 2016

On 2016-04-28 05:15, Zhanibek Adilbekov wrote:
> After upgrading tzdata to 2016d version some of applications unable
> to determine right timezone for all zones which belong to Kazakhstan.
> I personally use Asia/Almaty (which is +06:00 and no DST) on my
> machine (Arch Linux with Plasma 5.6), and it leads some programs to
> produce unexpected results. E.g.: Digital Clock applet shows -12
> hours from current time and Plasma Lockscreen shows time in UTC. I
> tried downgrade to 2016c and it works just fine.
> Please fix the issue, or at least return to previous state (which
> worked fine). Thanks!

Suggestions from previous plasma digital clock bug reports:

- Reapply 2016d.
- Check /etc/localtime links to or cmp to Asia/Almaty, and
   you have exported TZ=Asia/Almaty or TZ is unset.
- Check date -u, date, timedatectl, and hwclock output.
- Check time on analogue or another desktop clock app.
- Change your digital clock app local timezone to something else,
    check times, then change it back and check times.

Report upstream bug against clock app(s)!
These apps do not seem to handle DST transitions or time zone
changes properly.
Closing and relaunching the app or desktop may also make the
problem go away until the next change.

In general: suspect your own code before apps, and apps before
infrastructure, unless you can show the same symptom appears
in multiple apps.

Take care. Thanks, Brian Inglis, Calgary, Alberta, Canada

More information about the tz mailing list