[tz] [PATCH] Allow use of <direct.h> from Microsoft Windows to fix mkdir() parameters

Paul Eggert eggert at cs.ucla.edu
Sun Feb 28 23:22:57 UTC 2016

Ian Abbott wrote:
> The "HAVE_DECL_ASCTIME_R" name seems to break the current naming convention (if
> there is one) though!

Thanks for checking it.

The idea is that HAVE_DECL_FOO is 1 if 'foo' is declared in a system .h file, 
whereas HAVE_FOO is 1 if 'foo' exists in the library as a function.  The 
convention is not perfect, as there is an ambiguity if a function's name begins 
with 'decl_', but it should be good enough in practice.

More information about the tz mailing list