[tz] [PROPOSED 2/5] Pacify gcc -std=c89 -pedantic with new attributes
Brian.Inglis at SystematicSw.ab.ca
Tue Nov 29 20:21:47 UTC 2022
On 2022-11-28 12:47, Paul Eggert via tz wrote:
> On 2022-11-28 05:40, Philip Newton wrote:
>> "have has" is a bit ugly....
> Yes, I originally used the name "HAVE___HAS_C_ATTRIBUTE", since it tests whether
> __has_c_attribute exists and that's the naming convention, but I changed it to
> HAVE_HAS_C_ATTRIBUTE as I worried that the three adjacent underscores would be
> confusing. If people prefer HAVE___HAS_C_ATTRIBUTE we can easily change to that.
> The longer name would be more consistent.
The special operator __has_c_attribute (operand) may be used in ‘#if’ and
‘#elif’ expressions in C code to test whether the attribute referenced by its
operand is recognized by GCC in attributes using the ‘[]’ syntax."
How about HAVE_C23_ATTRIBUTE_CHECK, HAVE_C2X_ATTRIBUTE_CHECK, or something
similarly more meaningful and less confusing?
Take care. Thanks, Brian Inglis Calgary, Alberta, Canada
La perfection est atteinte Perfection is achieved
non pas lorsqu'il n'y a plus rien à ajouter not when there is no more to add
mais lorsqu'il n'y a plus rien à retirer but when there is no more to cut
-- Antoine de Saint-Exupéry
More information about the tz